Build fails, nsprpub is missing

Discussion and announcements regarding the Mac port… er, original version of Oolite.

Moderators: another_commander, winston

Post Reply
User avatar
maik
Wiki Wizard
Wiki Wizard
Posts: 1885
Joined: Wed Mar 10, 2010 12:30 pm
Location: Ljubljana, Slovenia (mainly industrial, feudal, TL12)

Build fails, nsprpub is missing

Post by maik »

I'm trying to build Oolite from source on macOS Catalina, in Xcode 11.4. I cloned the git repository, and following the instructions in readme.md I would only have to open the .Xcode project, and hit the run button to compile. What happens is that I get an error messages stating, correctly, that "Build input file cannot be found: '/Users/maik/Projects/oolite/oolite/deps/mozilla/nsprpub/pr/src/md/unix/uxproces.c' and so on. The directory ~/Projects/oolite/oolite/deps/mozilla/ does not contain anything indeed.

Am I missing some step?

Thank you, kind regards,
-Maik

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 422
Joined: Sat Aug 09, 2014 4:16 pm

Re: Build fails, nsprpub is missing

Post by Commander_X »

It's very likely you forgot to run "git submodule update --init" after your cloning command.
The Oolite source is available from github.
Use `git clone https://github.com/OoliteProject/oolite`
to retrieve. Then `git submodule update --init`
to fetch the various submodules.
You can quickly check this if any of the "deps" folders are populated.

User avatar
maik
Wiki Wizard
Wiki Wizard
Posts: 1885
Joined: Wed Mar 10, 2010 12:30 pm
Location: Ljubljana, Slovenia (mainly industrial, feudal, TL12)

Re: Build fails, nsprpub is missing

Post by maik »

Thank you, that helped, I did not look further down in the readme.md after the "Building" headline :oops:

Now I am running into an error with libstdc++ being deprecated though, in the build target jsoplengen, project libjs:
clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated]
ld: library not found for -lstdc++
clang: error: linker command failed with exit code 1 (use -v to see invocation)
I guess this is due to using the latest Xcode, does someone know how to work around this without going back to an earlier version?

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 422
Joined: Sat Aug 09, 2014 4:16 pm

Re: Build fails, nsprpub is missing

Post by Commander_X »

Yea, that sounds familiar.
My last OS X incursion (one and a half or two years ago) required some ... merciless adjustments, as far as I remember (and I don't remember what they were :oops: )

Post Reply