Oolite Bulletins

For information and discussion about Oolite.
It is currently Fri Dec 15, 2017 10:05 am

All times are UTC




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
 Post subject: debug in xcode
PostPosted: Sun Feb 03, 2008 10:35 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jun 05, 2007 10:43 pm
Posts: 1263
Location: Berlin
It has been weeks since I could start oolite in debug using xcode 3.0 on leopard.

Jut wondering if this is a problem with my setup, or with the current codebase?

It runs fine with "Run".

It gets as far as Initializing universe.... and never gets any further. There is nothing of interest (to me) in the log:

[dataCache.rebuild.datesChanged]: Cache is stale (modification dates have changed). Rebuilding from scratch.
[script.javaScript.context.create]: Creating JS context.
[script.javaScript.context.create]: Creating JS context.
[script.load.world.listAll]: Loaded 14 world scripts: "Behemoth-script01", "black_monks", "Cargo_test", "clipperschedule", "ExecutiveFlightSchedule", "newskim", "OO-Haul Escort", "oolite-cloaking-device" 1.71, "oolite-constrictor-hunt" 1.71, "oolite-nova" 1.71, "oolite-thargoid-plans" 1.71, "oolite-trumbles" 1.71, "Pi-Forty-Two Con stores", "Put_Pirate_Coves_where_the_pirates_are"
[debugOXP.load.success]: Debug OXP loaded successfully.
[dataCache.willWrite]: About to write data cache.
[dataCache.write.success]: Wrote data cache.
[entity.linkedList.verify.error]: Broken x_next <PlayerEntity 0xbeca00>{"Cobra Mark III" ID: 100 position: (9301.64, -57266.3, 372449) scanClass: CLASS_PLAYER status: STATUS_DOCKED} list (38) ***
[entity.linkedList.verify.rebuild]: Rebuilding all linked lists from scratch

Closing log at 2008-02-03 22:29:53 +0000.





Seems to be in Universe initWithGameView around
Code:
#if OOLITE_MAC_OS_X
	//// speech stuff
	speechSynthesizer = [[NSSpeechSynthesizer alloc] init];
	


Top
   
 Post subject:
PostPosted: Mon Feb 04, 2008 9:04 am 
Offline
Grand Admiral Emeritus
Grand Admiral Emeritus
User avatar

Joined: Sat Apr 02, 2005 2:43 pm
Posts: 6657
Location: Sweden
That’s weird. It worked for me yesterday.

_________________
E-mail: jens@oolite.org


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited