What is going on!!!!

For test results, bug reports, announcements of new builds etc.

Moderators: winston, another_commander, Getafix

Post Reply
User avatar
Staer9
---- E L I T E ----
---- E L I T E ----
Posts: 570
Joined: Fri Feb 18, 2011 4:53 pm
Location: Hatfield, Hertfordshire (poor industrial)

What is going on!!!!

Post by Staer9 » Mon Apr 23, 2012 1:58 pm

Ok, I'd just done some editing to my shipset and I decided to launch oolite (stable V1.76) with only my shipset in the addons folder (so I would only be told the errors in that rather than in all my un-finished oxps) and after loading it looks like this:

http://www.imgpaste.com/sIux.jpg

No, I havn't decided to blur all the text on the page, it actually looks like that.
I re-installed oolite to no avail

Log looks like this:

Code: Select all

14:48:57.743 [log.header]: Opening log for Oolite version 1.76 (x86-32 test release) under Windows at 2012-04-23 14:48:57 +0100.
4 processors detected.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

14:48:57.944 [display.mode.list.native]: Windows native resolution detected: 1280 x 1024
14:48:58.327 [joystick.init]: Number of joysticks detected: 0
14:48:58.354 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
    Resources
    ../AddOns
    ../AddOns/Basic-debug.oxp
    ../AddOns/Staer9's Shipset (non-shadered)BETA-v0.1.7.oxp
14:48:58.354 [rendering.opengl.version]: OpenGL renderer version: 2.1.0 ("2.1.0 - Build 8.15.10.2119"). Vendor: "Intel". Renderer: "Intel(R) HD Graphics".
14:48:58.355 [rendering.opengl.extensions]: OpenGL extensions (82):
GL_ARB_texture_env_crossbar, GL_EXT_abgr, GL_ARB_shadow, GL_IBM_texture_mirrored_repeat, GL_EXT_separate_specular_color, GL_EXT_texture_edge_clamp, GL_EXT_blend_minmax, GL_EXT_draw_buffers2, GL_ARB_texture_env_add, GL_EXT_framebuffer_blit, GL_EXT_transform_feedback, GL_ARB_texture_env_dot3, GL_EXT_framebuffer_object, GL_EXT_blend_subtract, GL_3DFX_texture_compression_FXT1, GL_NV_conditional_render, GL_ARB_multitexture, GL_EXT_stencil_wrap, GL_ARB_texture_border_clamp, GL_ARB_framebuffer_sRGB, GL_ARB_texture_env_combine, GL_EXT_texture_env_add, GL_EXT_packed_pixels, GL_SGIS_texture_edge_clamp, GL_ARB_depth_texture, GL_SGIS_texture_lod, GL_ARB_occlusion_query, GL_ARB_transpose_matrix, GL_NV_texgen_reflection, GL_EXT_stencil_two_side, GL_ARB_shading_language_100, GL_ARB_texture_compression_rgtc, GL_EXT_texture_shared_exponent, GL_EXT_rescale_normal, GL_ARB_pixel_buffer_object, GL_EXT_secondary_color, GL_ARB_half_float_pixel, GL_EXT_blend_equation_separate, GL_EXT_draw_range_elements, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_ARB_half_float_vertex, GL_EXT_texture_swizzle, GL_SGIS_generate_mipmap, GL_ARB_texture_rectangle, GL_ARB_texture_non_power_of_two, GL_ARB_point_sprite, GL_EXT_packed_depth_stencil, GL_ARB_vertex_shader, GL_EXT_texture_compression_s3tc, GL_ARB_depth_buffer_float, GL_ARB_draw_instanced, GL_ARB_vertex_buffer_object, GL_WIN_swap_hint, GL_ARB_color_buffer_float, GL_ARB_shader_objects, GL_ATI_separate_stencil, GL_EXT_packed_float, GL_EXT_texture_rectangle, GL_ARB_texture_rg, GL_ARB_fragment_shader, GL_EXT_fog_coord, GL_EXT_texture3D, GL_ARB_window_pos, GL_ARB_fragment_program, GL_ARB_vertex_program, GL_EXT_texture_env_combine, GL_ARB_point_parameters, GL_ARB_texture_cube_map, GL_EXT_bgra, GL_EXT_compiled_vertex_array, GL_ARB_vertex_array_object, GL_ARB_draw_buffers, GL_ARB_texture_compression, GL_EXT_multi_draw_arrays, GL_ARB_texture_float, GL_EXT_blend_func_separate, GL_EXT_texture_sRGB, GL_EXT_shadow_funcs, GL_EXT_clip_volume_hint, GL_EXT_blend_color, GL_NV_blend_square
14:48:58.359 [rendering.opengl.shader.support]: Shaders are supported.
14:48:58.359 [speech.synthesis]: Spoken messages are off.
14:48:58.590 [script.load.world.listAll]: Loaded 5 world scripts:
    oolite-cloaking-device 1.76
    oolite-constrictor-hunt 1.76
    oolite-nova 1.76
    oolite-thargoid-plans 1.76
    oolite-trumbles 1.76
14:49:00.300 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'No connection could be made because the target machine actively refused it.

' (outStream status: 7, inStream status: 7)."
14:49:00.300 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'unknown error.' (outStream status: 0, inStream status: 0)."
14:49:00.300 [debugTCP.connect.failed]: Failed to connect to debug console at address 127.0.0.1:8563.
14:49:00.379 [loading.complete]: ========== Loading complete. ==========
14:49:32.972 [script.load.world.listAll]: Loaded 5 world scripts:
    oolite-cloaking-device 1.76
    oolite-constrictor-hunt 1.76
    oolite-nova 1.76
    oolite-thargoid-plans 1.76
    oolite-trumbles 1.76
14:50:36.669 [gameController.exitApp]: .GNUstepDefaults synchronized.

Closing log at 2012-04-23 14:50:36 +0100.
nothing in there that I've never seen before (but hey! my shipset hasn't got any errors!)

any ideas?
Image

richard.a.p.smith
Deadly
Deadly
Posts: 174
Joined: Mon Jun 07, 2010 9:03 am

Re: What is going on!!!!

Post by richard.a.p.smith » Sun Apr 29, 2012 8:39 pm

Hi. I just found out something that causes this on my laptop - Intel chipset. I changed a couple of settings in the 3D bit of the control panel and went from clear text to exactly the same type of mess you saw. In 3D settings the defaults under Custom Settings are Balance for Texture Quality, Application Settings for Anisotropic Filter and Vertical Sync and Default Settings for Vertex Processing. I changed Texture Quality to Performance and Vertex Processing to Application Settings. Oolite then showed the blurry mess. I then changed Texture Quality (only) back to Balance and the screen was once again okay.

So, maybe only one letter out in what's causing the trouble? :roll: Oh, how they laughed . . .

Richard

Post Reply