Oolite Bulletins

For information and discussion about Oolite.
It is currently Fri Nov 24, 2017 2:52 pm

All times are UTC




Post new topic  Reply to topic  [ 95 posts ]  Go to page Previous 13 4 5 6 7 Next
Author Message
PostPosted: Mon Aug 21, 2017 1:05 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sun Jul 19, 2015 1:09 pm
Posts: 419
@phkb some more issues:

- in the mission in which you receive an e-mail from a stranger asking for a meeting, the first time I reached the system I could not find the Meeting Point beacon on my Advanced Compass. I quit Oolite, restart from my save game 2 systems before that and this time the Meeting Point was in the Adv. Compass.
- but like before, once I meet the person and give the password nothing happens. This time I did not greet the other ship, I started by sending the passcode which was confirmed to be correct. What is supposed to happen next? All 3 times I tried it absolutely nothing happens.
- you mentioned I could try selling the equipment to hack the witchspace beacon via some non-legal routes, but I can't find that option on a Space Bar, for instance.


Top
   
PostPosted: Mon Aug 21, 2017 1:44 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Thanks, gsagostinho. I'll check these out and add the fixes to the next release.

Edit: I can confirm the bug with the "Request to meet" mission, and how it isn't getting past the passcode step. Also confirmed is the WBSA device not initiating correctly.
The issue of the meeting point waypoint not appearing was a "feature" I have decided actually isn't. Next version will fix this.
Selling the left over equipment required Smugglers OXP, and you have to go into the Black market screen.

Testing of the next version is progressing well, I should have a new version in the next couple of days.

_________________
My OXP's


Top
   
PostPosted: Thu Aug 24, 2017 8:02 pm 
Offline
Competent
Competent
User avatar

Joined: Thu Mar 30, 2017 9:57 pm
Posts: 50
Many thanks to you phkb for incorporating asteroids into the list of options :D
It has made the process of finding asteroids a more guided process (as opposed to wandering around relying on blind luck).

I have noticed one thing when using the Range Finder which is that whilst the Range Finder MFD is running I can use my ore processor or bulk cargo processor and not use any energy whatsoever (using either of these 2 devices normally drains your energy banks). For some reason whilst the Range Finder MFD is running it seems to keep your energy banks at full instead of draining them.
On the plus side this has masked the problem of my poor choice of Auxiliary Energy Generator in my current ship which the game won't give me an option to uninstall (but that's another matter and another expansion).


Top
   
PostPosted: Thu Aug 24, 2017 8:16 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sun Jul 19, 2015 1:09 pm
Posts: 419
@phkb thank you so much, I will test it as soon as I have a chance. I will also keeping reporting any issues here.
Quote:
Selling the left over equipment required Smugglers OXP, and you have to go into the Black market screen.
I see, I will try that next time :)


Top
   
PostPosted: Thu Aug 24, 2017 10:12 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Quote:
For some reason whilst the Range Finder MFD is running it seems to keep your energy banks at full instead of draining them.
That's not a bug, it's a feature!

Ahem.

Thanks for letting me know! I'll check this one out too. It might even make the cut for the next GalCop Missions release!

_________________
My OXP's


Top
   
PostPosted: Fri Aug 25, 2017 3:27 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
OK, confirmed bug on the Range Finder - it wasn't deducting any energy at all! Fixed in the next version (due out soon...)

_________________
My OXP's


Top
   
PostPosted: Fri Aug 25, 2017 7:58 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
OK, version 0.1.0 is now available. In this version:
  • Added some missions using Satellites OXP (types 110, 111, 113, 115, 122, 124).
  • Fixed issue where emailed missions, or missions delivered via another ship, were not checking all the conditions, giving the player a mission they couldn't complete.
  • Fixed issue with "Request for meeting" missions, where the target would not respond when the passcode was transmitted.
  • Added additional text to mission briefing for missions that require an interstellar space destination to make it clearer this is required.
  • Added additional text to mission briefing to make it clearer when a mission requires the player to return to the source system in order to complete it.
  • Applied distance and player score bonuses to Special delivery missions (type 40).
  • Fixed issue with the WBSA device not being startable when the beacon is targeted.
  • Fixed issue with the Range Finder not creating an energy drain.
  • Mission text tweaks.

_________________
My OXP's


Top
   
PostPosted: Fri Aug 25, 2017 5:59 pm 
Online
Competent
Competent
User avatar

Joined: Thu Nov 19, 2015 10:51 am
Posts: 46
Location: Galaxy 1
Hi - Just completed my first mission to deliver 6t of wine. Customer very happy, and tipped well!
In previous versions tried to find a derelict ship on otherside of planet, but ran out of time, couldn't find it, space is a vast place.
Attempted Interstellar mission to destroy 6 Thargoids - I wasn't very successful... think I will stick to delivering wine.

Really enjoying the missions, and latest version (0.1.0) seems to work well.

Having an issue with the mission to collect Thargoid wreckage, I collect a few tons 5/16, and head back to Esteonbi, which is the Originating system, but I don't know what to do with the wreckage. Tried selling some, but still doesn't contribute to the % mission complete.
It says To Complete Return to station in source system, which I suppose is Esteonbi?


Top
   
PostPosted: Fri Aug 25, 2017 9:23 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
Quote:
I don't know what to do with the wreckage
If you have the all the wreckage you should be able to go to the mission page and complete the mission. What I propbably haven't done is allow for a partial complete and continue, where you can give what you've collected then go back out and get some more. The completion time also probably needs to be extended for this reason.
Thanks for the feedback!

_________________
My OXP's


Top
   
PostPosted: Sat Aug 26, 2017 2:06 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
A quick patch to version 0.1.1, fixes the Collect Thargoid wreckage mission which had a bug, and makes the mission have an unlimited time frame.

_________________
My OXP's


Top
   
PostPosted: Sat Aug 26, 2017 8:52 pm 
Online
Competent
Competent
User avatar

Joined: Thu Nov 19, 2015 10:51 am
Posts: 46
Location: Galaxy 1
Quote:
A quick patch to version 0.1.1, fixes the Collect Thargoid wreckage mission which had a bug, and makes the mission have an unlimited time frame.
Having unlimited time seems to fit into the scenario better.

Tested this and when collecting alloy from the wreckage, the script now correctly deals with the cargo.

My existing mission terminated, due to running out of time, and didn't seem to accept some of the wreckage i'd collected. So starting a new Thargoid wreckage collection mission :)


Thanks.


Top
   
PostPosted: Sun Aug 27, 2017 12:58 pm 
Offline
Competent
Competent
User avatar

Joined: Thu Mar 30, 2017 9:57 pm
Posts: 50
Quote:
OK, confirmed bug on the Range Finder - it wasn't deducting any energy at all! Fixed in the next version (due out soon...)
Apologies to you phkb, I think that I haven't explained myself properly.
What I was saying is that previously with the range finder running in the background, if I then activated the ore processor or bulk cargo processor (which should drain energy when in use) was not previously happening.
Since the update the the ore processor and bulk cargo processor now drain energy at the correct rate but the range finder now seems to drain energy at an rapid rate, with nothing else running but the range finder my energy banks are spent after approx 40 seconds.
I am wondering if there is maybe an issue with my save file as I don't seem to be receiving the option to buy a naval energy grid when at a tech level 15 system (I had one on my previous ship), nor do I get the option to remove / buy QTHI energy generator equipment (oxp is installed and I have High Tech Light Auxiliary Energy Generator fitted - ohh - just checked on my equipment list (f5) and noticed that this item appears as Uninstall High Tech Light Auxiliary Energy Generator.
Darn - that aint right at all
Can anyone tell me if my save is correctable / recoverable?


Top
   
PostPosted: Sun Aug 27, 2017 8:01 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
It's unlikely to be your save file. I probably have the drain set too high on the range finder. One question though - what sort of ship are you flying?

_________________
My OXP's


Top
   
PostPosted: Mon Aug 28, 2017 5:16 am 
Offline
Average
Average

Joined: Tue Aug 02, 2016 6:17 am
Posts: 15
I'm unable to complete the thargoid wreckage collect alloys mission even though I have the required amount to turn in. The alloys were scooped up during battle in thargoid space after forced misjump. Seems bugged because after I go to the BB at the main station, it shows I have 0 out of 7 alloys when I have the 7 alloys in my cargo hold.


Top
   
PostPosted: Mon Aug 28, 2017 6:00 am 
Offline
Commodore
Commodore
User avatar

Joined: Tue Jan 21, 2014 10:37 pm
Posts: 1806
Location: [p]laying [h]ard and [k]icking [b]utt somewhere in G7...
And this is with the latest version, right?

_________________
My OXP's


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 95 posts ]  Go to page Previous 13 4 5 6 7 Next

All times are UTC


Who is online

Users browsing this forum: Cmd Northgate and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited