Oolite Bulletins

For information and discussion about Oolite.
It is currently Fri Sep 22, 2017 12:56 am

All times are UTC




Post new topic  Reply to topic  [ 58 posts ]  Go to page Previous 1 2 3 4 Next
Author Message
 Post subject:
PostPosted: Wed Aug 20, 2008 7:51 am 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Quote:
Quote:
Instructions:

Unzip the file, and then move the folder "Aquatics 1.01.oxp" to the AddOns directory of your Oolite installation. Then start the game up and the ships should be added.
From the pods readme file, yes I'm one of those and no I don't read eula's :)
Looks like I need to update my version of Aquatics.
Great work Thargoid looking forward to a big payday or not as the case may be.
Oops! :oops: Corrected version uploaded ;)

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Fri Aug 22, 2008 11:36 am 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
A final (for now) version of Pods is now available, with some new pods, both good and bad. Also some are available as UPS versions via the bolt-on, for use with Eric Walsh's UPS-Courier OXP (which needs to be installed - the cross-link is deliberate as it doesn't make much sense to have Pods-UPS without UPS Courier).

The pods added are fuel, missile, large capacity, empty, trumble (ok, so I succumbed), piggybank, jamming, retry, exploding (scoop) and exploding (hull-breaching).

Available via the wiki OXP page or the link below.

Editted to add - now including a late hidden bug-fix to the large capacity pods.

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Thu Aug 28, 2008 11:56 am 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Thu Dec 14, 2006 9:08 am
Posts: 9520
Location: a Hacker Outpost in a moderately remote area
Found a bug in pods. The logfile says:
Quote:
[script.javaScript.exception.22]: ***** JavaScript exception: TypeError: player.fuelLeakRate is not a function
[script.javaScript.exception.22]: /Applications/Spiele/Oolite 1.71.2/AddOns/Pods 1.00.oxp/Scripts/pods_fuelpod.js, line 20.
What it means is that in the pods_fuelpod.js-script you treated player.fuelLeakRate as if it was a function. But it is a property. So in order to set the leak rate you simply have to set it, not execute a function with an argument.

In other words, simply replace this
Code:
			player.fuelLeakRate(10);
with this
Code:
			player.fuelLeakRate = 10;
and you'll be fine.

_________________
The Story — The Career — The OXPs


Top
   
 Post subject:
PostPosted: Sun Aug 31, 2008 7:19 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Thanks. File updated.

I think this (plus many other) OXP will need another tweak soon to make it 1.72 compatible (for the player.ship introduction), but that's for another day I think.

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Thu Nov 06, 2008 1:46 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
...and that day is today.

v1.72 friendly version of both OXPs are now available from my wiki page (link below), although the UPS one won't work until a v1.72 version of UPS Courier is available.

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Thu Nov 06, 2008 3:38 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Mon Jan 31, 2005 4:16 pm
Posts: 2157
Location: Berkshire, UK
Well done matey, you're leading the way in updating OXP's to 1.72.

I'm slightly confused though, there are 10 OXP's under your name on your Wiki link and they all show requires either 1.71, 1.70 or 1.65, so which two have you updated?

_________________
The Grey Haired Commander has spoken!
OK so I'm a PC user - "you know whats scary? Out of billions of sperm I was the fastest"


Top
   
 Post subject:
PostPosted: Thu Nov 06, 2008 4:16 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Sorry, should have been more clear. "Both" meant both Pods OXPs (the main one and the UPS add-on). Also on the wiki page, the requirements originally listed were the minimum requirements. I've amended the page to be more clear, and to also show which OXPs I've got around to checking/updating.

At the moment the V1.72 updated OXPs are Pods (both main and UPS addon OXPs, with the noted caveat that a new version of UPS-Courier is needed too for Pods-UPS), Aquatics, Traffic Control, Welcome Mat and Drones.

The others should fairly much work (with log warnings) except Missile Rack, which is giving problems with the like_ship/is_template issue. I'm ploughing through them though, and now feeling the pain of having been quite so prolific in producing OXPs :roll: :lol:

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Sun Dec 14, 2008 10:05 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Just found that I missed one of the scripts when I updated things for 1.72, so the ton type of large pods won't work properly (thanks Screet for the heads-up).

Anyway I've just made the correction and uploaded a new version, for anyone who has this OXP installed.

- = = Pods = = -

- = = Pods-UPS = = -

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Thu Apr 09, 2009 9:38 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Due to the error reported in the logs here with the awarding of cargo where it won't fit, I've updated both Pods and Pods-UPS to a new version with the check in place.

I've also taken the opportunity to alter the code for the trumble pod to prevent it possibly spoiling the inbuilt trumble mission.

Download either from the links in the post above, or via those in my sig. It also now needs v1.72 or above, didn't see the point in keeping v1.71 compatibility.

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Sun Nov 01, 2009 6:55 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Just updated these pair of OXPs to v1.10.

Not much changed, just specifically set them all to scanClass CLASS_CARGO (rather than relying on the like_ship picking it up - leading apparently to some hostile cargo pods in some cases) and also added a few extra roles for cross-OXP compatibility.

Download Pods 1.10 and Pods-UPS from Box.net via those links or the ones below.

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Mon Nov 02, 2009 7:27 pm 
Offline
Competent
Competent

Joined: Fri Jun 27, 2008 9:45 pm
Posts: 40
Hi Thargoid,

I get an error message saying:
Code:
[shipData.load.begin]: Loading ship data...
  [plist.parse.foundation.failed]: Failed to parse ../AddOns/Pods 1.10.oxp/Config/shipdata.plist as a property list using Foundation. Retrying using homebrew parser. WARNING: the homebrew parser is deprecated and will be removed in a future version of Oolite.
Parse failed at line 107 (char 2568) - unexpected character (wanted ';' or '}')
    [plist.homebrew.parseError]: Property list isn't in XML format, homebrew parser can't help you.


Top
   
 Post subject:
PostPosted: Mon Nov 02, 2009 7:39 pm 
Offline
Slightly Grand Rear Admiral
Slightly Grand Rear Admiral
User avatar

Joined: Sat Jun 16, 2007 3:48 pm
Posts: 5536
Location: Netherlands
Quote:
Hi Thargoid,

I get an error message saying:
Code:
[shipData.load.begin]: Loading ship data...
  [plist.parse.foundation.failed]: Failed to parse ../AddOns/Pods 1.10.oxp/Config/shipdata.plist as a property list using Foundation. Retrying using homebrew parser. WARNING: the homebrew parser is deprecated and will be removed in a future version of Oolite.
Parse failed at line 107 (char 2568) - unexpected character (wanted ';' or '}')
    [plist.homebrew.parseError]: Property list isn't in XML format, homebrew parser can't help you.
I bet it are those trumbles again :P

Specially around the 107th they are very active.

_________________
UPS-Courier & DeepSpacePirates & others at the box and some older versions


Top
   
 Post subject:
PostPosted: Mon Nov 02, 2009 8:15 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
Yup, it was indeed, damn things! :oops:

Corrected version uploaded, the roles on the trumblepod seem to have suffered somehow from a wandering quotation mark...

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Thu Dec 31, 2009 8:12 pm 
Offline
Thargoid
Thargoid
User avatar

Joined: Thu Jun 12, 2008 6:55 pm
Posts: 5509
New version (1.11) of both OXPs now uploaded to box.net, to cure the script bug in the trumblepod (would be!) that was causing the rogue addition of cargo when it shouldn't.

Oh and as people seemed to prefer it to be a nicer OXP, I've toned down the role probabilities of some of the less nice ones...

_________________
My OXPs via Boxspace or from my Wiki pages :D.

Thargoid TV
Dropbox Referral Link


Top
   
 Post subject:
PostPosted: Fri Jan 01, 2010 12:17 am 
Offline
---- E L I T E ----
---- E L I T E ----

Joined: Sun Sep 20, 2009 10:24 am
Posts: 433
Location: California
Thanks Thargoid!,

Currently though, I'm under the gun to pay back a Black Monk loan, so the extra cargo has come in handy, I'll update after I pay back the loan.
:)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 58 posts ]  Go to page Previous 1 2 3 4 Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited