Oolite Bulletins

For information and discussion about Oolite.
It is currently Fri Nov 24, 2017 2:54 pm

All times are UTC




Post new topic  Reply to topic  [ 177 posts ]  Go to page Previous 18 9 10 11 12
Author Message
PostPosted: Sat Jul 25, 2015 2:31 pm 
Online
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12925
Location: Corke's Drift
Quote:
The problem with these, as I see it, is two-fold.. firstly, the person who downloads it probably won't ever get to see what the core game is like, on its own, and secondly, if it's not made very clear beforehand that certain OXPs are included (and how to remove them if desired), they may get totally the wrong idea about Oolite, particularly if they don't like the effect they have on gameplay.
<nods>

_________________
The only good fnord is a dead fnord!


Top
   
PostPosted: Sat Jul 25, 2015 2:42 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 15, 2012 4:19 am
Posts: 2469
Location: Finland
Quote:
Quote:
The problem with these, as I see it, is two-fold.. firstly, the person who downloads it probably won't ever get to see what the core game is like, on its own, and secondly, if it's not made very clear beforehand that certain OXPs are included (and how to remove them if desired), they may get totally the wrong idea about Oolite, particularly if they don't like the effect they have on gameplay.
<nods>
Nevertheless, compo-packs are a better alternative to pre-packaging OXPs. I'm still in favor of a dedicated category for compo-packs or consistently using Systems category. We can't get rid of them after all.


Top
   
PostPosted: Sat Jul 25, 2015 2:49 pm 
Online
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 12925
Location: Corke's Drift
Quote:
We can't get rid of them after all.
No, we can't. In some ways, the OXZ manager is out of control.

_________________
The only good fnord is a dead fnord!


Top
   
PostPosted: Sat Jul 25, 2015 7:28 pm 
Offline
Dangerous
Dangerous
User avatar

Joined: Thu Jun 04, 2015 7:53 pm
Posts: 110
Quote:
Quote:
Quote:
...which are what remains of the packages that come installed with the fedora Oolite RPM...
:shock: Is there really a distro out there that packages some OXPs with Oolite? That's a new one.
Hmm.. that's rather disturbing and concerning, actually.

Mazur, could you tell us a bit more about this particular RPM, please? What version of Oolite is it? Doing some googling around, the present maintainer for the RPM appears to be Richard W.M. Jones <rjones@r*dh*t.com>, but so far as I can see that's just for v1.80 of Oolite. Is your RPM an official Redhat/Fedora release, or an unofficial one from some other repository?
Oops. Totally overlooked all this discussion.
*looking through the Oolite he installed for clues as to its origin*
There is a release.txt that mentions only this: 1.82.0.6556-150526-a3b98dd
I thought it was a Fedore 21 package, but my yum and rpm report no Oolite in any form.

So I'm thinking they came with the binary release of 1.82: https://github.com/OoliteProject/oolite ... ux-x86.tgz

HTH, HAND.

_________________
User Mazur, Commander Vatta, Hyperspace Delivery Boy.
Squeaky clean, utterly harmless, rank amateur.


Top
   
PostPosted: Sat Jul 25, 2015 9:33 pm 
Online
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5017
Quote:
So I'm thinking they came with the binary release of 1.82: https://github.com/OoliteProject/oolite ... ux-x86.tgz
There is only one OXP installed with the official Oolite binaries and it is the Debug.oxp, which is required for communication with the Debug Console. It is installed only with the Developer Release version of the game.


Top
   
PostPosted: Sun Jul 26, 2015 12:20 am 
Offline
Dangerous
Dangerous
User avatar

Joined: Thu Jun 04, 2015 7:53 pm
Posts: 110
Quote:
Quote:
So I'm thinking they came with the binary release of 1.82: https://github.com/OoliteProject/oolite ... ux-x86.tgz
There is only one OXP installed with the official Oolite binaries and it is the Debug.oxp, which is required for communication with the Debug Console. It is installed only with the Developer Release version of the game.
Yes, it looked like that, when i downloaded it earlier today. Then the only remaining explanation is, that I downloaded some packages by hand and installed them, unpacked, in /opt/Oolite/AddOns/, but I don't remember doing so, nor why I would have picked the particular OXPs for such treatment.

Still, I can't rule out that I did.

_________________
User Mazur, Commander Vatta, Hyperspace Delivery Boy.
Squeaky clean, utterly harmless, rank amateur.


Top
   
PostPosted: Thu Aug 17, 2017 12:18 am 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon May 20, 2013 9:53 pm
Posts: 2427
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
I fixed a typo in Superhub for Extra Planets v1.1 around sfep_market.js. Thank you phkb for spotting!

_________________
OXPs by Norby


Top
   
PostPosted: Thu Aug 17, 2017 1:09 pm 
Offline
Competent
Competent
User avatar

Joined: Thu Mar 30, 2017 9:57 pm
Posts: 50
Is anyone having any difficulty updating to the latest "Superhub for Extra Planets 1.1)?
Each time i attempt to update via the in-game update manager the download fails.
:?


Top
   
PostPosted: Thu Aug 17, 2017 1:26 pm 
Online
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5017
The reason for the failed download is listed inside the log:
Quote:
[oxz.manager.error]: Downloaded OXZ does not have the same identifer and version as expected. This might be due to your manifests list being out of date - try updating it.


Top
   
PostPosted: Thu Aug 17, 2017 1:27 pm 
Offline
Competent
Competent
User avatar

Joined: Thu Mar 30, 2017 9:57 pm
Posts: 50
Following the fail message from the oxp manager - I've had a quick look at the Latest.log (can't pretend that I know what I am looking at in all honesty) but I did notice a series of outputs which included the following :
13:49:40.103 [version.debug]: oolite.oxp.Norby.Superhub_for_Extra_Planets mv:1.0 mav:1.1
13:49:40.265 [oxz.manager.error]: Downloaded OXZ does not have the same identifer and version as expected. This might be due to your manifests list being out of date - try updating it.

Can anyone advise if this is the issue (or part of it) and what I need to do to remedy the issue I'm experiencing.

Many thanks in advance for any help or guidance that anyone can offer.


Top
   
PostPosted: Thu Aug 17, 2017 1:37 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Mon May 20, 2013 9:53 pm
Posts: 2427
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Thank you for the report, my bad is fixed now, try again please.

_________________
OXPs by Norby


Top
   
PostPosted: Thu Aug 17, 2017 1:41 pm 
Offline
Competent
Competent
User avatar

Joined: Thu Mar 30, 2017 9:57 pm
Posts: 50
The update has taken fine now.

Many thanks to everyone for their help :D


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 177 posts ]  Go to page Previous 18 9 10 11 12

All times are UTC


Who is online

Users browsing this forum: Cmd Northgate, Yahoo [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited