Oolite Bulletins

For information and discussion about Oolite.
It is currently Mon Oct 15, 2018 5:41 pm

All times are UTC




Post new topic  Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Tue Mar 27, 2012 8:26 am 
Offline
Poor
Poor

Joined: Tue Mar 27, 2012 8:14 am
Posts: 6
Hi all,

I have read a lot of threads on this board but could not find an answer my limited computing knowledge could understand!

You all seem to be an incredibly helpful and friendly bunch (after all this is the friendliest bulletin board this side of Riedquat!) I wonder if someone can help.

I have an Asus Intel i3-2330 laptop with the 3000 onboard chipset.

the problem I have is with glitching on space stations, big ships eg black monks monetary and planets.

On space stations and ships, as I approach I cab see through areas as they alternate between being opaque and transparent, with planets a jagged dark area appears on the planet and moves around as I approach, only disappearing when I am very close.

Any help would be very much appreciated


Top
   
PostPosted: Tue Mar 27, 2012 8:55 am 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Aug 29, 2006 5:02 pm
Posts: 2073
Location: Norway
Welcome misterjof, to the friendliest board this side of Riedquat, as you have already discovered.
I assume you are on Windows, since you are posting in the PC part of the forum. I'm no specialist in the graphics arena, but while we are waiting for the "smart" people to arrive, a few quick points.
Could you list OS-version please. Also, it would be great if you could post your latest log file. This will reveal what OpenGL extensions are supported by your current drivers, and whether you are on no, simple or full shaders, and possibly other problems with your installation.
You can find the log in:

C:\Oolite\Oolite.app\Logs

Assuming that you have installed Oolite to the default directory. Copy the content of the text file "latest.log" and post it here.

_________________
"A brilliant game of blasting and trading... Truly a mega-game... The game of a lifetime."
(Gold Medal Award, Zzap!64 May 1985).


Top
   
PostPosted: Tue Mar 27, 2012 12:39 pm 
Offline
Poor
Poor

Joined: Tue Mar 27, 2012 8:14 am
Posts: 6
Hi Gimi.

Thanks for the welcome.

I will update the thread with as much info as I can and my logs a bit later on today when I have my laptop on.

Many thanks


Top
   
PostPosted: Tue Mar 27, 2012 7:22 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Thu Dec 14, 2006 9:08 am
Posts: 9520
Location: a Hacker Outpost in a moderately remote area
I'm by no means an expert, but "Intel onboard chipset" doesn't sound good. I think there are a couple of threads around which come to the conclusion that those are not capable of running Oolite (I think because of lack of capability to run OpenGL properly, but as I said, I'm no expert).

_________________
The Story — The Career — The OXPs


Top
   
PostPosted: Tue Mar 27, 2012 7:46 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Sun Jan 08, 2012 11:32 pm
Posts: 293
Location: Brussels
Quote:
I have an Asus Intel i3-2330 laptop with the 3000 onboard chipset.

the problem I have is with glitching on space stations, big ships eg black monks monetary and planets.

On space stations and ships, as I approach I cab see through areas as they alternate between being opaque and transparent, with planets a jagged dark area appears on the planet and moves around as I approach, only disappearing when I am very close.
Quote:
I'm by no means an expert, but "Intel onboard chipset" doesn't sound good. I think there are a couple of threads around which come to the conclusion that those are not capable of running Oolite (I think because of lack of capability to run OpenGL properly, but as I said, I'm no expert).
I'm using a Intel HD Graphics 3000 onboard chipset on a Thinkpad E520 laptop (Linux Xubuntu OS), Oolite runs fine here.

The chipset may not be the best around, but it is capable of handling Oolite with full shaders. Sometimes it behaves like an "older chipset", as illustrated here, but none of the glitches as reported by misterjof.


Top
   
PostPosted: Tue Mar 27, 2012 8:24 pm 
Offline
Commodore
Commodore
User avatar

Joined: Fri Feb 25, 2011 8:46 am
Posts: 1127
Location: UK South Coast.
This sounds like a known problem with current Oolite 1.76 and HD3000. See http://www.aegidian.org/bb/viewtopic.ph ... 55#p162124. It's been fixed in the trunk (current source code), so a current nightly build (from http://www.aegidian.org/bb/viewtopic.php?f=8&t=6852) should not have these problems. However as this is the under development version of Oolite it may have other bugs.

_________________
[EliteWiki] Capt. Murphy's OXPs
External JavaScript resources - W3Schools & Mozilla Developer Network
Win 7 64bit, Intel Core i5 with HD3000 (driver rev. 8.15.10.2696 - March 2012), Oolite 1.76.1


Top
   
PostPosted: Tue Mar 27, 2012 10:03 pm 
Offline
Poor
Poor

Joined: Tue Mar 27, 2012 8:14 am
Posts: 6
Hi all,

Thank you very much for your help.

I am running windows 7 service pack 1 (6.1.7601)

driver is 8.15.10.2653

graphics is integrated intel HD graphics 3000.

My log is below,

22:34:48.782 [log.header]: Opening log for Oolite version 1.76 (x86-32 test release) under Windows at 2012-03-27 22:34:48 +0100.
4 processors detected.
Build options: spoken messages, mass/fuel pricing, JavaScript console support, OXP verifier, localization tools, debug GraphViz support, JavaScript profiling.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

22:34:49.540 [display.mode.list.native]: Windows native resolution detected: 1366 x 768
22:34:50.893 [joystick.init]: Number of joysticks detected: 0
22:34:51.342 [dataCache.rebuild.datesChanged]: Cache is stale (modification dates have changed). Rebuilding from scratch.
22:34:51.343 [searchPaths.dumpAll]: Unrestricted mode - resource paths:
Resources
../AddOns
../AddOns/accessoriesV2.1.oxp
../AddOns/AsteroidStorm 4.02.oxp
../AddOns/Basic-debug.oxp
../AddOns/DeepspaceHud.oxp
../AddOns/Diso.oxp
../AddOns/Hawksound.oxp
../AddOns/hOopyCasino1.2.oxp
../AddOns/Lave Academy 1.31.oxp
../AddOns/longway 1.1.oxp
../AddOns/Missionaries.oxp
../AddOns/Shady_blackmonks.oxp
../AddOns/Smivs'Shipset-v4-SD-replace.oxp
../AddOns/UPS-courier v1.7.8.oxp
22:34:51.343 [rendering.opengl.version]: OpenGL renderer version: 3.1.0 ("3.1.0 - Build 8.15.10.2653"). Vendor: "Intel". Renderer: "Intel(R) HD Graphics 3000".
22:34:51.343 [rendering.opengl.extensions]: OpenGL extensions (114):
GL_NV_primitive_restart, GL_ARB_texture_env_crossbar, GL_EXT_abgr, GL_ARB_shadow, GL_IBM_texture_mirrored_repeat, GL_EXT_separate_specular_color, GL_EXT_texture_edge_clamp, GL_EXT_blend_minmax, GL_EXT_draw_buffers2, GL_ARB_texture_env_add, GL_ARB_draw_elements_base_vertex, GL_ARB_sampler_objects, GL_EXT_framebuffer_blit, GL_EXT_transform_feedback, GL_ARB_texture_env_dot3, GL_ARB_texture_query_lod, GL_EXT_framebuffer_object, GL_EXT_blend_subtract, GL_3DFX_texture_compression_FXT1, GL_NV_conditional_render, GL_ARB_vertex_array_bgra, GL_EXT_texture_snorm, GL_ARB_multitexture, GL_EXT_stencil_wrap, GL_ARB_texture_border_clamp, GL_ARB_framebuffer_sRGB, GL_ARB_texture_env_combine, GL_EXT_framebuffer_multisample, GL_EXT_texture_env_add, GL_EXT_packed_pixels, GL_SGIS_texture_edge_clamp, GL_ARB_depth_clamp, GL_INTEL_performance_queries, GL_ARB_uniform_buffer_object, GL_ARB_depth_texture, GL_SGIS_texture_lod, GL_ARB_occlusion_query, GL_ARB_transpose_matrix, GL_NV_texgen_reflection, GL_EXT_stencil_two_side, GL_ARB_seamless_cube_map, GL_ARB_fragment_program_shadow, GL_ARB_shading_language_100, GL_ARB_texture_compression_rgtc, GL_EXT_gpu_program_parameters, GL_EXT_texture_shared_exponent, GL_EXT_rescale_normal, GL_ARB_map_buffer_range, GL_ARB_provoking_vertex, GL_ARB_explicit_attrib_location, GL_ARB_pixel_buffer_object, GL_EXT_secondary_color, GL_ARB_copy_buffer, GL_ARB_half_float_pixel, GL_EXT_blend_equation_separate, GL_EXT_draw_range_elements, GL_ARB_instanced_arrays, GL_EXT_texture_lod_bias, GL_EXT_texture_filter_anisotropic, GL_ARB_half_float_vertex, GL_EXT_texture_swizzle, GL_SGIS_generate_mipmap, GL_ARB_timer_query, GL_ARB_texture_rectangle, GL_ARB_texture_non_power_of_two, GL_ARB_point_sprite, GL_EXT_packed_depth_stencil, GL_ARB_vertex_shader, GL_EXT_texture_compression_s3tc, GL_EXT_texture_integer, GL_ARB_depth_buffer_float, GL_ARB_sync, GL_ARB_draw_instanced, GL_ARB_vertex_buffer_object, GL_WIN_swap_hint, GL_ARB_color_buffer_float, GL_ARB_shader_objects, GL_ARB_texture_rgb10_a2ui, GL_EXT_texture_array, GL_ATI_separate_stencil, GL_ARB_framebuffer_object, GL_EXT_packed_float, GL_ARB_compatibility, GL_EXT_texture_rectangle, GL_ARB_texture_rg, GL_ARB_occlusion_query2, GL_ARB_fragment_shader, GL_EXT_fog_coord, GL_EXT_texture3D, GL_ARB_vertex_type_2_10_10_10_rev, GL_ARB_texture_buffer_object_rgb32, GL_ARB_window_pos, GL_ARB_fragment_program, GL_ARB_vertex_program, GL_EXT_texture_env_combine, GL_ARB_point_parameters, GL_ARB_texture_cube_map, GL_EXT_bgra, GL_EXT_compiled_vertex_array, GL_ARB_multisample, GL_ARB_vertex_array_object, GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, GL_ARB_texture_compression, GL_EXT_multi_draw_arrays, GL_ARB_fragment_coord_conventions, GL_ARB_texture_float, GL_EXT_blend_func_separate, GL_EXT_texture_sRGB, GL_EXT_shadow_funcs, GL_ARB_shader_bit_encoding, GL_EXT_clip_volume_hint, GL_EXT_blend_color, GL_NV_blend_square
22:34:51.401 [rendering.opengl.shader.support]: Shaders are supported.
22:34:51.401 [speech.synthesis]: Spoken messages are off.
22:34:52.302 [shipData.load.begin]: Loading ship data.
22:34:56.924 [script.load.world.listAll]: Loaded 16 world scripts:
AsteroidStorm 4.02
black_monks
hoopy_casino 1.2
LaveAcademy 1.2
long_way_round
missionaries
oolite-cloaking-device 1.76
oolite-constrictor-hunt 1.76
oolite-nova 1.76
oolite-thargoid-plans 1.76
oolite-trumbles 1.76
ups_container 1.7.7
ups_docs 1.7.7
ups_parcel 1.7.7
ups_slaves 1.7.7
ups_sun 1.7.7
22:35:04.499 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'No connection could be made because the target machine actively refused it.

' (outStream status: 7, inStream status: 7)."
22:35:04.499 [debugTCP.disconnect]: No connection to debug console: "Connection to debug console failed: 'unknown error.' (outStream status: 0, inStream status: 0)."
22:35:04.499 [debugTCP.connect.failed]: Failed to connect to debug console at address 127.0.0.1:8563.
22:35:06.262 [loading.complete]: ========== Loading complete. ==========
22:35:14.113 [script.load.world.listAll]: Loaded 16 world scripts:
AsteroidStorm 4.02
black_monks
hoopy_casino 1.2
LaveAcademy 1.2
long_way_round
missionaries

Thanks again!

Just a couple of quick questions if someone can help also.

1. As I do not have a joystick would you recommend keys or mouse, I tried mouse but had a really hard time with it.

2. If, as a previous poster suggests, I need to install a 'nightly build' is this an easy thing to do? Apologies for my lach of technical knowledge.


Top
   
PostPosted: Tue Mar 27, 2012 10:55 pm 
Offline
Sharp Shooter Spam Assassin
Sharp Shooter Spam Assassin
User avatar

Joined: Sat Jul 04, 2009 9:31 pm
Posts: 13376
Location: Corke's Drift
Hi misterjof and welcome aboard.
Quote:
If, as a previous poster suggests, I need to install a 'nightly build' is this an easy thing to do?
Installing the trunk nightly should be simple. Download the Windows package from here, run the .exe and install. It'll sit happily alongside Oolite 1.76.

_________________
But I wish, me my friend, I could sail to the stars
Have the gift to transport
My whole being, my whole thought
To a world of dreams, my friend


Top
   
PostPosted: Wed Mar 28, 2012 4:21 am 
Offline
Commodore
Commodore
User avatar

Joined: Fri Feb 25, 2011 8:46 am
Posts: 1127
Location: UK South Coast.
Quote:
with planets a jagged dark area appears on the planet and moves around as I approach, only disappearing when I am very close.
I should add that this part of the issue has a different cause and appears to a bug in the graphics driver. Older drivers revisions (released early 2011) were fine and it is fixed for me in the most recent driver revision available from the Intel website, which is 8.15.10.2656 - released on 22/2/12 - http://downloadcenter.intel.com/SearchR ... Drivers%0A
Quote:
1. As I do not have a joystick would you recommend keys or mouse, I tried mouse but had a really hard time with it.
My preference is mouse over keys any day - but it takes a bit of getting used to if you haven't used it as a control method before in other flight/space type games. If you need to adjust sensitivity you can do so via the windows control panel.

_________________
[EliteWiki] Capt. Murphy's OXPs
External JavaScript resources - W3Schools & Mozilla Developer Network
Win 7 64bit, Intel Core i5 with HD3000 (driver rev. 8.15.10.2696 - March 2012), Oolite 1.76.1


Top
   
PostPosted: Wed Mar 28, 2012 5:52 am 
Offline
Poor
Poor

Joined: Tue Mar 27, 2012 8:14 am
Posts: 6
Thank you very much captain.

All seems to be well now, I have updated my driver and installed windows updates. Planets now appear in all their glory!

My main issue with mouse control was the sensitivity so I will look at changing under the control panel. I might try using u,a,s,d together with mouse to control speed and yaw, with pitch and roll on the mouse.

Many thanks to everyone for your help.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited