Oolite Bulletins

For information and discussion about Oolite.
It is currently Tue Oct 23, 2018 4:09 pm

All times are UTC




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Tue Jul 12, 2011 7:39 pm 
Offline
---- E L I T E ----
---- E L I T E ----
User avatar

Joined: Wed Aug 08, 2007 10:59 pm
Posts: 545
Location: Netherlands
When oolite is built with MAKEFLAGS -j1 (like on a single socket / singlecore cpu) , the built is succesfull.

However, If compiled with makeflags -j2 or more, the build of libjs fails .

Her's the relevant part of the build script with a workaround for compiling it with -j2 (or higher) :
Code:
    cd ${srcdir}/${pkgname}-build/deps/Cocoa-deps/scripts
    ./update-mozilla.sh
    mkdir -p ${srcdir}/${pkgname}-build/deps/Cross-platform-deps/mozilla/js/src/build-release
    cd ${srcdir}/${pkgname}-build/deps/Cross-platform-deps/mozilla/js/src/build-release
    ../configure --disable-shared-js --enable-threadsafe --with-system-nspr --disable-tests --enable-trace-jscalls
    cd ${srcdir}/${pkgname}-build
    make -f libjs.make debug=no
    make -f Makefile release
The problems appear only in the libjs part.

_________________
OS : Arch Linux 64-bit - rolling release

OXPs : My user page

I am subscribed to the threads for my oxps, if you need my attention just post in them or send a pm.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: Baidu [Spider] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited