Oolite Bulletins

For information and discussion about Oolite.
It is currently Thu Apr 19, 2018 7:35 pm

All times are UTC




Post new topic  Reply to topic  [ 12 posts ] 
Author Message
 Post subject: 1.73 on Linux?
PostPosted: Mon Aug 31, 2009 4:04 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Dec 05, 2006 9:43 pm
Posts: 8501
Location: Newbury, UK
Ok, with the flurry of activity over 1.73 - what's the best way to get it on my linux box) - I haven't done anything on since 1.72.2 and 'fess I can't remember what to do and in the various threads - Winston's bleeding edge nightly's doesn't appear to be (when you follow the link to the status page) and I'm not quite sure (anymore) if Getafix's Ubuntu install is relevant for 1.73...

Apologies if I'm just being dumb... :oops:

_________________
Quote:
Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here


Top
   
 Post subject:
PostPosted: Mon Aug 31, 2009 4:08 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral

Joined: Wed Feb 28, 2007 7:54 am
Posts: 5121
I was just talking to Getafix and he is in the process of generating the Linux 1.73 autopackage. Hopefully we will have something up very soon.


Top
   
 Post subject:
PostPosted: Mon Aug 31, 2009 4:26 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Dec 05, 2006 9:43 pm
Posts: 8501
Location: Newbury, UK
Faber-rooney! (must stop watching The Tweenies with the kids)

_________________
Quote:
Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here


Top
   
 Post subject:
PostPosted: Fri Sep 04, 2009 8:29 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Linux will go for 1.73.1 release.

Cheers.

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject:
PostPosted: Fri Sep 04, 2009 8:32 pm 
Offline
Intergalactic Spam Assassin
Intergalactic Spam Assassin
User avatar

Joined: Tue Dec 05, 2006 9:43 pm
Posts: 8501
Location: Newbury, UK
Quote:
Linux will go for 1.73.1 release.

Cheers.
8)

Nice to see you back on the forums!

_________________
Quote:
Apparently I was having a DaddyHoggy moment.
Oolite Life is now revealed here


Top
   
 Post subject:
PostPosted: Fri Sep 04, 2009 10:30 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Nice to be back. 8)

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 3:45 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Has anyone tried to install 1.73.2 on a fresh (without oolite dev environment installed) Ubuntu 9.04?

When installing the .deb for 1.73.2, if it complaints about missing dependencies then do:
Code:
sudo apt-get -f install
and accept the download (active internet connection is needed).

This will install any missing libraries. 8)

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 5:57 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Sep 02, 2008 2:01 pm
Posts: 815
Location: London, UK
I did test them on a virgin VirtualBox before uploading them, yes. They should pull in all dependencies.

Is there a problem?

_________________
The glass is twice as big as it needs to be.


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 7:39 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
I did the same on Ubuntu 9.04 VirtualBox and
it failed by reporting the missing dependencies.

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 8:20 pm 
Offline
Commodore
Commodore
User avatar

Joined: Tue Sep 02, 2008 2:01 pm
Posts: 815
Location: London, UK
Exactly how did you try to install the packages?

I must admit, I initially only tested that the packages work, so 'cheated' and used the repository I set up which means download/install is fully integrated into the Ubuntu GUI tools and hence very easy.

But I just tried by downloading and installing the packages directly, and on my virgin install, they got opened via the GDebi package installer, which is a GUI tool and automatically downloads and installs any missing dependencies.

_________________
The glass is twice as big as it needs to be.


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 9:03 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
What I did was:
Code:
sudo bash
dpkg -i oolite-data_1.73.2-1_all.deb
dpkg -i oolite_1.73.2-1_i386.deb

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
 Post subject:
PostPosted: Sun Sep 06, 2009 9:19 pm 
Offline
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
User avatar

Joined: Tue Apr 01, 2008 12:55 pm
Posts: 889
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Following an investigation it seems that
Code:
sudo apt-get -f install
is the official way to install .deb files and their dependencies (at least for Ubuntu).

Case closed. 8)

_________________
Xubuntu 14.04LTS / Windows 7 Home Premium
Intel Core 2 Quad Q9450 2.66GHz - 6GB DDR2 - Palit GeForce GTX 750 Ti StormX Dual (2048MB DDR5)
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited