[Solved] Not able to install Oolite on Linux Mint 17 "Qiana"

For discussion of ports to POSIX based systems, especially using GNUStep.

Moderators: winston, another_commander, Getafix

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

[Solved] Not able to install Oolite on Linux Mint 17 "Qiana"

Post by Cmdr. Keen » Mon Dec 22, 2014 2:12 am

Hello gang.

I had Oolite 1.80 installed in Linux Mint 17 but performance was so bad that I finally un-installed Oolite and decided to just play the game from a different (lighter) distro. i.e. Lubuntu; installed on a separate partition.

Then I discovered that Mint was using the wrong GPU driver so I want to re-install Oolite again but I just can't get it to install. What am I doing wrong?

The method I use to install Oolite is by simply double clicking on the link to the oolite-1.80.linux-x86_64.run shell script as I have always done but nothing happens when I do.
I have also right clicked on the link and selected 'Execute' the results are the same. I really want to get it installed so that I can test my theory, that the wrong GPU driver was causing the performance hit.

Any help or advice would be greatly appreciated.

By the way, I'm using the Xfce desktop environment if that makes a difference. :wink:

Thank you in advance.

CK
Last edited by Getafix on Tue Jan 06, 2015 3:04 pm, edited 1 time in total.
Reason: Marked as 'Solved'

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Norby » Mon Dec 22, 2014 9:52 am

Welcome Cmdr. Keen!

Try run it in a terminal window to see the error message. For example type:

Code: Select all

cd /home/yourloginname/Downloads
./oolite-1.80.linux-x86_64.run
If you got "permission denied" then allow execution:

Code: Select all

chmod +x ./oolite-1.80.linux-x86_64.run
Else Otherwise please post the message here.
Last edited by Norby on Mon Dec 22, 2014 2:48 pm, edited 1 time in total.

User avatar
spud42
---- E L I T E ----
---- E L I T E ----
Posts: 1191
Joined: Wed Mar 26, 2014 10:11 am
Location: Brisbane,Australia

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by spud42 » Mon Dec 22, 2014 11:30 am

nice if then else code there norby but its not indented correctly... lol
Arthur: OK. Leave this to me. I'm British. I know how to queue.
OR i could go with
Arthur Dent: I always said there was something fundamentally wrong with the universe.
or simply
42

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Norby » Mon Dec 22, 2014 3:10 pm

spud42 wrote:nice if then else code there norby but its not indented correctly... lol
Well maybe "Otherwise" is better? I never speak in english just write translated hungarian words which surely sounds funny for a native speaker sometimes. :)

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Cmdr. Keen » Tue Dec 23, 2014 12:48 am

Norby wrote:Welcome Cmdr. Keen!

Try run it in a terminal window to see the error message. For example type:

Code: Select all

cd /home/yourloginname/Downloads
./oolite-1.80.linux-x86_64.run
If you got "permission denied" then allow execution:

Code: Select all

chmod +x ./oolite-1.80.linux-x86_64.run
Else Otherwise please post the message here.
Thank you Norby for the advice. (and the kind welcome) Your instructions worked perfectly. The install went without error, however, when I try to launch the game from the Oolite menu option under <Games>, the game won't launch. Nothing happens that I can see, and there are no error messages.
I haven't tried to launch the game from a Terminal window yet. I will try that next and post back with results.

Thank you again,

Kindest Regards
CK

User avatar
spud42
---- E L I T E ----
---- E L I T E ----
Posts: 1191
Joined: Wed Mar 26, 2014 10:11 am
Location: Brisbane,Australia

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by spud42 » Tue Dec 23, 2014 10:41 am

Norby wrote:
spud42 wrote:nice if then else code there norby but its not indented correctly... lol
Well maybe "Otherwise" is better? I never speak in english just write translated hungarian words which surely sounds funny for a native speaker sometimes. :)
not at all... your english is better than mine . I was born in England but have lived in Australia for 48 years so i speak fluent Aussie.....
Arthur: OK. Leave this to me. I'm British. I know how to queue.
OR i could go with
Arthur Dent: I always said there was something fundamentally wrong with the universe.
or simply
42

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Cmdr. Keen » Wed Dec 24, 2014 2:58 am

I have to admit that I am at a loss here. :(
I have tried to launch the game from a Terminal by typing .oolite and all I get is a message that says "The program 'oolite' is currently not installed. You can install it by typing:
sudo apt-get install oolite".
I have even tried the same command from the directory where Oolite is installed and the same thing.

I'm sure it's something that I'm doing wrong but I don't have a clue what that is. :?

Any assistance would be greatly appreciated.

CK

Commander_X
---- E L I T E ----
---- E L I T E ----
Posts: 262
Joined: Sat Aug 09, 2014 4:16 pm

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Commander_X » Wed Dec 24, 2014 5:39 am

Cmdr. Keen wrote:I have to admit that I am at a loss here. :(
I have tried to launch the game from a Terminal by typing .oolite and all I get is a message that says "The program 'oolite' is currently not installed.
<didn't install Oolite from the installer in a while, mostly compiling and running it from the source, but, still ... />
After installing you should have 2 options (IIRC):

1. If you installed is as a root, for all users, running oolite (not .oolite -- note the missing point) in Terminal, should do. Otherwise the whole path to the executable should be something like: /usr/lib/GNUstep/Applications/Oolite/oolite (or /usr/lib64/[...], if your Linux is x86_64)

2. If you installed it only for your user, then the command line to start it in terminal should be:
~/GNUstep/Applications/Oolite/oolite

But because you try to start it from the Games menu in Xfce, and it doesn't work, you can try to open the ~/.Oolite/Logs/Latest.log file, with a text editor, and see if there are any issues reported there (maybe post the contents here and someone would give you some hints).

NB The ~ in the filenames points to your home directory in the Linux shell of your Terminal window.

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Getafix » Wed Dec 24, 2014 8:34 am

Cmdr. Keen wrote:I have to admit that I am at a loss here. :(
I have tried to launch the game from a Terminal by typing .oolite ...
If you followed Cmdr Norby's instructions you should have a non-privileged installation,
therefore please, open a terminal window and execute:

Code: Select all

$ ~/GNUstep/Applications/Oolite/oolite
Post here any error message that pops-up.


I would also like to check one more thing.
Please, go to the Oolite menu option under Games, then right click on it and check the properties.
What is the execute command?
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Getafix » Wed Dec 24, 2014 8:42 am

Commander_X wrote:...
1. If you installed is as a root, for all users, running oolite (not .oolite -- note the missing point) in Terminal, should do. Otherwise the whole path to the executable should be something like: /usr/lib/GNUstep/Applications/Oolite/oolite (or /usr/lib64/[...], if your Linux is x86_64)
...
When installing Oolite as root, using the oolite.org package, the Oolite executable path is

Code: Select all

/usr/local/bin/oolite
Typically this is included in the PATH environment variable, so you can just execute

Code: Select all

$ oolite
in a terminal window.

The path you mention, I think, is the path when installing Oolite from the Linux repository. :?
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Cmdr. Keen » Thu Dec 25, 2014 4:49 am

Commander_X wrote:
<didn't install Oolite from the installer in a while, mostly compiling and running it from the source, but, still ... />
After installing you should have 2 options (IIRC):

1. If you installed is as a root, for all users, running oolite (not .oolite -- note the missing point) in Terminal, should do. Otherwise the whole path to the executable should be something like: /usr/lib/GNUstep/Applications/Oolite/oolite (or /usr/lib64/[...], if your Linux is x86_64)

2. If you installed it only for your user, then the command line to start it in terminal should be:
~/GNUstep/Applications/Oolite/oolite
I installed Oolite into my own user directory because this computer has only one user (me) and isn't a part of any network so I didn't see any benifit to installing it to the root directory.
Commander_X wrote: But because you try to start it from the Games menu in Xfce, and it doesn't work, you can try to open the ~/.Oolite/Logs/Latest.log file, with a text editor, and see if there are any issues reported there (maybe post the contents here and someone would give you some hints).
I looked at the Latest.log but I'm afraid it doesn't make any sense to me. :?
Here is a copy of my Latest.log for your review:
Opening log for Oolite version 1.80 (x86-64) under Linux 3.13.0-24-generic at 2014-12-24 17:41:22 -0600.
1 processor detected.
Build options: OpenAL, new planets.

Note that the contents of the log file can be adjusted by editing logcontrol.plist.

17:41:25.121 [oxp.conflict]: OXP oolite.oxp.Lone_Wolf.ShieldCyclerNext.oxz conflicts with oolite.oxp.Lone_Wolf.ShieldCycler.oxz and was removed from the loading list
17:41:25.127 [dataCache.rebuild.pathsChanged]: Cache is stale (search paths have changed). Rebuilding from scratch.
17:41:26.290 [display.mode.list.native]: X11 native resolution detected: 1366 x 768

Closing log at 2014-12-24 17:41:26 -0600.
I did notice that there appear to be OXP conflicts listed in the Latest.log.....this has to have something to do with the vanilla install of Oolite because I haven't installed any addon's at this point.
Thank you for your help Commander_X.
It is greatly appreciated.

CK

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Cmdr. Keen » Thu Dec 25, 2014 5:16 am

Getafix wrote: If you followed Cmdr Norby's instructions you should have a non-privileged installation,
therefore please, open a terminal window and execute:

Code: Select all

$ ~/GNUstep/Applications/Oolite/oolite
Post here any error message that pops-up.
Following the above instructions led to the following output:
keen@The-Keen-Machine ~ $ ~/GNUstep/Applications/Oolite/oolite

It seems that your operating system does not have a valid timezone name
configured and is using an abbreviation instead. By comparing timezone
file data it is has been possible to find the actual timezone used, but
doing that is a slow process.

You can avoid slowness of this time zone detecting approach
by setting the environment variable TZ='America/Chicago'
Or You can override the timezone name by setting the 'Local Time Zone'
NSUserDefault via the 'defaults' command line utility, a Preferences
application, or some other utility.
eg "defaults write NSGlobalDomain 'Local Time Zone' 'America/Chicago'"

AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
X Error of failed request: GLXUnsupportedPrivateRequest
Major opcode of failed request: 156 (GLX)
Minor opcode of failed request: 16 (X_GLXVendorPrivate)
Serial number of failed request: 26
Current serial number in output stream: 27
AL lib: (EE) alc_cleanup: 1 device not closed

Erk. It looks like Oolite died with an error. When making an error
report, please copy + paste the log above into the report.

(Press Ctrl-C to continue)
Getafix wrote: I would also like to check one more thing.
Please, go to the Oolite menu option under Games, then right click on it and check the properties.
What is the execute command?
I did as you instructed Getafix however, there isn't an option for "preferences" in the "right click" menu.
The only options present are Oolite.org (which is greyed out), and three others; Add to Favorites, Add to Desktop and Add to Panel.
This wouldn't be to first time that I had an install of Linux that didn't behave as expected. :roll: lol!

I have several other Linux distributions installed on other partitions and Oolite is installed on a couple of them and I haven't had any issues (other than very slow performance). Linux Mint is the only distribution that I have had a problem getting Oolite to install to and run from.

Thank you for you help with this issue my friend. I really appreciate it.
Perhaps I should delete Oolite and try to re-install it??

Awaiting further instructions.

Kindest Regards
CK

User avatar
Norby
---- E L I T E ----
---- E L I T E ----
Posts: 2543
Joined: Mon May 20, 2013 9:53 pm
Location: Budapest, Hungary (Mainly Agricultural Democracy, TL10)
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Norby » Thu Dec 25, 2014 9:25 am

Cmdr. Keen wrote:there isn't an option for "preferences"
Try "Add to desktop" and right click on the created icon.
Cmdr. Keen wrote:AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
X Error of failed request: GLXUnsupportedPrivateRequest
So only your sound and graphics are not working? :shock: Have you sound and 3D graphics in other programs?
Check the Failed to initialize backend "pulse" and Mesa driver discussions.
Cmdr. Keen wrote:OXP conflicts listed in the Latest.log
This is a notice that an oxp will not be loaded due to another, but the spinning cobra should be appear regardless of this.

Check the log after you got the main menu, at that time you will see the path of your oxps. For example mine:

Code: Select all

~/.Oolite/AddOns
~/GNUstep/Applications/Oolite/AddOns
~/GNUstep/Library/ApplicationSupport/Oolite/ManagedAddOns/

User avatar
Getafix
Quite Grand Sub-Admiral
Quite Grand Sub-Admiral
Posts: 960
Joined: Tue Apr 01, 2008 12:55 pm
Location: A small ice asteroid, orbiting Oresrati in Galaxy 8 (a.k.a. northwest Armorica).
Contact:

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Getafix » Fri Dec 26, 2014 9:43 am

Cmdr. Keen wrote:...Perhaps I should delete Oolite and try to re-install it??...
Well, there is an uninstall script that you can execute:

Code: Select all

$ ~/GNUstep/Applications/Oolite/uninstall
However, I don't think that this will fix the case.
Later today I will try to simulate the issue by installing a Linux Mint virtual machine.

EDIT 2014/12/28 11:30
Having installed a vanilla Qiana, there doesn't seem to be any issue.
I also get the audio warnings you get, however Oolite starts with no issue; focus on fixing the 3D graphics issue first.

In the meantime
Norby wrote:
Cmdr. Keen wrote:there isn't an option for "preferences"
Try "Add to desktop" and right click on the created icon.
please, post the value of the "Command" property (in the Properties option, when you right click the newly created desktop icon).
"Any sufficiently advanced information is indistinguishable from noise." [Newman, Lachmann, Moore]

Cmdr. Keen
Poor
Poor
Posts: 7
Joined: Sun Dec 21, 2014 6:34 am

Re: Not able to install Oolite on Linux Mint 17 "Qiana"?

Post by Cmdr. Keen » Tue Dec 30, 2014 2:16 pm

First let me apologise for not responding sooner. The Holidays! :? glad it's almost over!

Second, thank you to everyone that responded to this post.

With the help and advice of everyone that responded, I have worked through the problem by following the steps and recommendations given and believe that I have found the problem/solution?

It seems that Mint was forcing the use of an incorrect GPU driver. The OS was defaulting to the legacy Mesa driver for this GPU instead of correctly recognizing and installing the correct video driver which was the Legacy Nvidia 304.125 version. I still question whether this is the best driver for this graphics processor but I will continue using it for now. I am going to upgrade to a better graphics card -- one that's newer and isn't built into the MB.

Anyhow, I installed the recommended driver for this GPU (an Nvidia gForce 7050) and now I am able to launch the game from the Main menu icon as well as from a Terminal and everything appears to be fine except for the performance during game play.

The game is so slow that it is not playable (4-5 fps max). But this is a seperate issue and I will post a new topic for this issue if I can't find a solution.

So, thank you all again for all your help and advice. It is appreciateded more than you can know.

With the utmost respect.
CK

Post Reply